[ic] IC/RH9 IC Server won't start - Please Help

AS news1 at dsl.pipex.com
Sat Oct 25 15:57:32 EDT 2003

> > Hi all,
> >
> > Hoping someone can help me out here, I have a clean install of RH9
> my
> > machine for development, I have tried loading the non threaded perl
> rpm
> > from the ftp site as well.
> >
> > I tried to load interchange but it kept complaining about missing
> > modules (even after installing the non-threaded rpm).
> >
> > I then tried loading the individual perl rpms that it was moaning
> about
> > but some of those wouldn't install because of perl conflicts.
> >
> > At this point I did a --nodeps install of
> IC/foundation/foundation-demo.
> >
> > I can get to the first page of IC where it has the Customer / Admin
> > choice, so apache is up and running ok.
> >
> > I can't get the server to run though, I get the following list of
> errors
> > when I try to restart the server. It looks like its complaining
> > perl quite a bit??
> >
> > I am a newbie to perl/linux & IC which doesn't help much.
> >
> > Thanks,
> > Andy.
> >
> ----
> >From your shell type perl -MCPAN -e 'install Bundle::Interchange'
> This will install the required perl modules
> Scott
> ----
> Hi,
> Well I tried that and lots of things flashed past on the screen, in
> meantime I had done a manual removal of the Perl5 directory and manual
> install of the kitchinsink perl5 file from the rh9 ftp directory.
> When I http to foundation I still can't get past the first screen, I
> still get the server not running message. Things look different now
> I try to restart the server, it says:-
> The interchange server was not running
> Low traffic settings
> Interchange v4.8.7
> Configuring catalog foundation....Using Default DBM database....done
> I have also tried doing a re-install without --nodeps and it is still
> complaining about missing perl modules.
> What can I do next, I can provide telnet access if anyone wants a
> Thanks,
> Andy.

Don't get too frustrated, I think everyone here at one point has had
type of problem.  I feel that the problem you are facing is a common
with RH 9.0 and perl.  Please take a look at these notes and see if this
helps you get past you problem.

 In shell copy this command
1) export LANG=en_us

In /etc/sysconfig/i18n alter it to be

In shell copy this command
3) perl -MCPAN -e 'install Bundle::Interchange'   (even though you did
before try it again now)

Now at this point watch the entire process and it may take awhile but
and see if you are running into any errors on install and auto testing
these modules.  Try to post what errors if any you may be receiving and
what modules, but by entering the  "export LANG=en_us" you may resolve a
of your past issues with the module installs.  For some reason RH 9.0
has an
issue with its default Lang config that conflicts with a couple perl
modules.  Then restart interchange and post what errors you see in your
error logs.  Just one last thing this will all be for not if your perl
install has not been configured correctly meaning:

" The perl rpm that installs by default on 9.0 is thread enabled which
not compatible with interchange you need to recompile perl with the
enabled set to 0 instead of 1 "

Let us know how it goes

Good Luck,

Sam Batschelet
Systems Engineer
ExactaSphere Inc.


Thanks for the help, I followed the above as all my lang settings were
set to GB as I am in the UK.

Anyway I ran the Bundle:: command again and it straight away says :-


What should I set the (unset) ones to?


More information about the interchange-users mailing list