[ic] Mysql Help, DBD::mysql won't install

AS news1 at dsl.pipex.com
Thu Oct 30 22:59:19 EST 2003

At 09:52 PM 10/30/2003 +0000, you wrote:
> > I have IC 4.8.7 working with its default database but when I try a
> > makecat and select mysql I get an error warning me about DBD::mysql
> > being missing.
> >
> > I have tried to install DBD:mysql but the following is the
> > what happens.
> >
> > I am running RH9 with non-threaded perl + bundle::interchange
> >
> > I am not very good with Linux, can someone tell me what's wrong
> >
> > Thanks,
> > Andy.
> >
> >
> > Transcript from trying to install DBD::mysql
> >
> >
> > [root at webdev bin]# perl -MCPAN -e 'install DBD::mysql'r-xr-x
> > -rwxr-xr-x    1 root     root       716052 Oct
> > Can't exec "mysql_config": No such file or directory at Makefile.PL
> > 174.
>Might sound abvious but do you have mySQL installed?
>Hi Sam,
>Yes I have 4.0.16 server rpm and client rpm installed, the server is
>running, I can run mysql and get a mysql> prompt and I have set a
>user=root password.
>I *think* the mysql install is ok but when I do an IC makecat it
>complains about perl module DBD::mysql

DBD::mysql's makefile is trying to get the mysql installation parameters

from mysql_config, but it can't find that executable in the usual paths
binaries (/usr/bin, /usr/local/bin, etc). You should 'find' or 'locate' 
mysql_config on your system, and symlink or copy it into one of the 
directories above. Alternately, you go into
and run MakeFile.PL with user-specified flags per the spec you get from

         perl Makefile.PL -h

Hi Ed et al,

I have tried find / -name 'mysql_config' and I cannot find the file? Any
idea why this would be?


More information about the interchange-users mailing list