[ic] Problems with mv_action

Jamie Neil jamie at versado.net
Mon Sep 8 14:25:00 EDT 2003

Hi All,

I've had the following piece of code running happily on my site for a 
month or so:

[set bounce_clickcode]
   [bounce href="[area href=|[cgi clickcode]|]"]
<form method="post" action="[process]">
<input type="hidden" name="mv_session_id" value="[data session id]">
<input type="hidden" name="mv_action" value="back">
<input type="hidden" name="mv_click" value="bounce_clickcode">
<input type="text" name="clickcode" class="navbar" maxlength="10" 
<input type="image" name="go" src="go.gif" alt="go">

It allows the user to enter a product code and go straight to the 
product's flypage. I use a bounce instead of "[area flypage]" to avoid 
having to make changes to the flypage code and so the url reads 
"1234.html" instead of "flypage.html".

Testing it today however, I found it had stopped working :(

After a lot of head scratching I managed to get it to work again by 
setting mv_todo instead of mv_action, however I'm not sure why this 
works as I don't really understand what the difference is between these 
two values. Can anyone enlighten me?

As to why it broke, well I think it might be my own stupid fault...

I often need to produce lists from a table and present them like this:

Item1, Item2, Item3, Item4 and Item5.

Where the first and last list elements are formatted differently to the 
rest. Up to now I have been doing this using *very* messy (and slow) 
if/then/else clauses, but I noticed last week that some new options had 
been added to the "prefix-alternate" tag that makes doing this very simple.

So I looked at the changes/diffs from my version (2.171) to the latest 
version (2.189) and as there didn't seem to be too much change apart 
from a few new features and some bug fixes, I decided to do some testing 
using the new module as a drop in replacement. I got no errors in the 
logs, everything seemed to work as before, ordering was ok, searching 
was ok, and the new alternate tags worked perfectly. So I upgraded the 
production server and everything seemed to be working fine until today I 
noticed this problem, and now I'm wondering what other issues I'm going 
to come across...

So my question is, has the behavior of the mv_action value been changed 
(I'm thinking maybe my earlier code only worked because of a bug) or 
have I unwittingly broken something by dropping in the new Interpolate 
code? If I have broken it, is it maybe possible to rectify it without 
doing either a wholesale upgrade to 4.9.8 or backing out to the 4.9.7 
version again?

Sorry for the long post.


Jamie Neil | <jamie at versado.net> | 0870 7777 454
Versado I.T. Services Ltd. | http://versado.net/ | 0845 450 1254

More information about the interchange-users mailing list