[ic] Perl advisory

Jason Lee jason.lee at mac.com
Wed Sep 24 00:28:21 EDT 2003

Mike Heins wrote:
> In any case, the update to Safe v1.09 is as simple as:
> 	perl -MCPAN -e 'install Safe'
> It takes seconds because it is such a small Perl-only module.

Hmm, I have the latest RH 7.3 updates and am not able to run the above 
command. Get this error:

  [root at titan root]# perl -MCPAN -e 'install Safe'
  Can't locate object method "install" via package "Safe" (perhaps you 
forgot to load "Safe"?) at -e line 1.

  [root at titan root]# perl -v

  This is perl, v5.6.1 built for i386-linux

Looks like I also have the unsafe Safe. ;)

  [root at titan root]# perl -MSafe -e 'print "$Safe::VERSION\n"'

I also looked to make sure Safe was there and it is installed in the 
following INC paths:

  Characteristics of this binary (from libperl):
   Compile-time options:
   Built under linux
   Compiled at Apr  1 2002 12:23:22

  [root at titan root]# locate Safe

Running kernel 2.4.20-18.7 on Athlon. As per Mike, I'm not going to be 
running any 'public' access into the admin portion, so it sounds like 
I'll be reasonably safe. However, the paranoid in me is still curious.

Any suggestions? Manual build of Safe maybe?


- Jason

More information about the interchange-users mailing list