[ic] AuthorizeNet Changes in 5.2

Bryan D Gmyrek gmyrek at U.Arizona.EDU
Tue Aug 10 14:57:10 EDT 2004

> >I'm getting the same authorizenet errors with interchange 4.9.4 running on
> >RedHat Enterprise Linux 3.
> >
> >authorizenet page:  response: HTTP/1.0 900 NET OR SSL ERROR
> >
> >SSL_write 29464: 1 - error:140790E5:SSL routines:SSL23_WRITE:ssl handshake
> >failure


One thing to check is the transaction version.  In 5.2 the
default transaction version is 3.1.  This is set in
lib/Vend/Payment/AuthorizeNet.pm, the variable is x_Version.
But the best thing to do is to go to secure.authorize.net and
update the transaction version to 3.1.

Not sure this will fix your problem though.  It seemed to help me
a bit.

BTW, this should be a variable one can set in interchange.cfg and
be in the docs.  I'd do it myself but am not sure how.


More information about the interchange-users mailing list