[ic] AuthorizeNet Changes in 5.2

Mike Heins mike at perusion.com
Tue Aug 10 18:21:45 EDT 2004

Quoting Bryan D Gmyrek (gmyrek at U.Arizona.EDU):
> > When I attempted to enter the card number again and submit it
> > came back with the same
> > 'MErrMsg' => 'Authorizenet error: . Please call in your order
> > but no SSL error.  In this case the transaction went through to
> > Authorize.net
> So I tried it a thrid time and third time was a charm.  Order
> went through normally.  WTF?
> I've grabbed the newest AuthorizeNet.pm from CVS but looking at
> the diffs I don't know if it will help much.
> Other info:
> Vend::Payment::AuthorizeNet payment module initialized, using Net::SSLeay
> Net:SSLeay, is the newest version according to
> perl -MCPAN -e 'install Net::SSLeay'

I recommend ditching Net::SSLeay and using Crypt::SSLeay only. Also,
make sure MaxServers is set to zero and that you have
PERL_SIGNALS=unsafe on your 5.8.2 or higher Perl.
Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.647.1295  tollfree 800-949-1889 <mike at perusion.com>

Research is what I'm doing when I don't know what I'm doing.
-- Wernher Von Braun

More information about the interchange-users mailing list