[ic] Virtual Installation Problems - keep getting "Can't write uid file"

D T dogtags at doglover.com
Sun Feb 1 11:42:01 EST 2004

Hi All

Interchange 5.0.0

Have done root tarball install many times, but virtual is proving troublesome.

Trying to install in virtual hosting account under /home/user/interchange. 

Source is located at /home/user/interchangesource. 

When I run the ./configure script, I get the following error:

opendir(./../..): Permission denied at /usr/lib/perl5/5.6.1/FindBin.pm line 143
Can't write uid file: Permission denied
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `test'.  Stop.

I searched the archives and found a few things.

1. Tried 'installopts' here:

but got the same error.

2. Tried cpan_local_install, everything installed, but still got the above error.

3. FindBin.pm
Marty, in the following thread, revised his FindBin.pm file. One problem for me is that I don't have the .bash file in my user directory. I have the .bash_history. So, I'm not sure how I could change the PATH to the revised FindBin.pm.


Would anyone know what else could be tried or have any suggestions?

Thanks very much.

Sign-up for Ads Free at Mail.com

More information about the interchange-users mailing list