[ic] Problem with Admin

Kurt Wolter kwolter at rochelle.net
Thu Feb 26 11:28:46 EST 2004

Mike Heins <mike at perusion.com> wrote ..
> Quoting Kurt Wolter (kwolter at rochelle.net):
> > (top of original post deleted)
> > When I makecat I use sensible answers and after i start the interchange
> > server i can get to the foundation catalog as a customer. But I get this
> > message:
> > 
> > [26/February/2004:00:46:44 -0500] catalog6 
> > /cgi-bin/catalog6/admin/index.html Runtime error: ichelp import failed:
> > sdbm store returned -1, errno 22, key "kaccess.main" at 
> > /usr/local/interchange/lib/Vend/Table/Common.pm line 485, <IN> line 3.
> > 
> > There were 3 previous posts about this same error from early january.
> > 
> > I believe I do have GDBM installed in perl.
> No, you cannot, for SDBM would not be used if you had it.

Okay. But in /usr/local/src/perl-5.8.0/ext there is both a GDBM_File/ and a SDBM_File/ directory. ( I am really stretching my understanding of Perl at this point, but...) I'm guessing that these are modules (extensions?) and that they either came with the Perl tarball or were added by Perl when I ran the CPAN install Interchange::Bundle (see original post for complete syntax). I think that I read somewheres that Perl's configure -d will examine the contents of /ext and make a best guess as to what modules to include in the build. 

So, is Perl's Configure -d smart enough to install GDBM and not SDBM though they are both there, or do I need to remove SDBM_File directory or setup Perl's config.sh to not install SDBM?

Or, is it behind door number 3?

On a side note, this whole messy process makes me wonder if there is a definitive tutorial for compiling Perl so that Interchange WILL work.  ??

Or perhaps it is my own error for trying to install Interchange on a Mandrake 9.1 which comes with threading Perl, which forced me to rebuild Perl in the first place, which may have opened the door for me rebuild Perl incorrectly. ?

More information about the interchange-users mailing list