[ic] Runtime error: DBD::Pg v5.0

Salvador Caballe scaballe at caballe.net
Mon Jan 5 12:24:49 EST 2004

On Sun, 04 Jan 2004 19:17:33 +0100
Salvador Caballe <scaballe at caballe.net> wrote:

> I just upgraded a system running interchange 4.8.7 to 5.0, my old catalog 
> runs OK with this new version, I use postgresql database in both catalogs, but 
> If I create a new catalog with makecat using the included foundation 
> template, all seems OK ,no errors when I start interchange.
> but  I have "500 Internal server error" when I call any page
> from the new foundation store , no problems with my old catalog
> this is the error.log file output:
> Runtime error: DBD::Pg::st execute failed: ERROR:  Unable to identify an 
> operator '<>' for types 'bpchar' and 'int4' at 
> /usr/local/interchange/lib/Vend/Table/DBI.pm line 1836.

Finally I solve the problem :

I upgrade postgresql 6.52 to 7.4.1
,DBI and DBD::Pg perl modules.

and now all is OK


More information about the interchange-users mailing list