[ic] Upgrading IC and Authorize.net Tip

Bryan D Gmyrek gmyrek at U.Arizona.EDU
Fri Jun 4 18:43:59 EDT 2004


I was having a lot of trouble with Authorize.net after upgrading
to 5.2 from the 4.8 branch.  Some transactions would go
through on authorize.net but post errors back to my site,
meaning the customer's card would get charged but the order
wouldn't go through.  Other orders would process fine.
After doing a deep search of the archives I found something
referencing the Transaction Version in
{interchange dir}/lib/Vend/Payment/AuthorizeNet.pm
The variable is
                x_Version                               => '3.1',
When I signed up for Authorize.net only last Fall the transaction
version on authorize.net was set at 3.0 so I left it that way.
When I noticed how the variable was set in AuthorizeNet.pm I
went in and changed the transaction version on secure.authorize.net to 3.1
and the problems _seem_ to have gone away.
Hope this helps someone else out there!


More information about the interchange-users mailing list