[ic] Installing Perl and Interchange 5.2

Jon Jensen jon at endpoint.com
Mon Jun 7 11:17:10 EDT 2004

On Mon, 7 Jun 2004, Ed Waldspurger wrote:

> I am preparing to install Interchange 5.2 on SuSE Linux 9.1. I have looked
> through the docs, and have searched the mailing list archive, but still have
> a few questions.
> A threaded version of Perl is already installed on the box, so I am going to
> be compiling a non-threaded version of Perl. Should this be done as root, or
> as the user interch? 

That's up to you. It's probably most useful to do it as root, as long as 
you install into /usr/local and leave the SuSE Perl build the way it is.

> Will I be able to use the rpm to install Interchange, or will I have to
> build it from the tarball? Again, should this be done as root, or as
> interch?

The RPMs need to be installed as root. I don't know whether they'll work 
on SuSE Linux or not; I've only tested them on Red Hat Linux and Fedora 

> How can I ensure that Interchange will find the proper version of Perl?

Build your own RPM from source, and in the specfile there's an option at 
the top specifying whether you're using a local perl build or not.

If you're not familiar with RPMs, it'll probably be easiest at this point 
to install Interchange from the tarball as the interch user.


More information about the interchange-users mailing list