[ic] RHEL3.0/Interchange5.0 Build Question

Jon Jensen jon at endpoint.com
Fri Mar 12 12:09:22 EST 2004

On Fri, 12 Mar 2004, Steve Lush wrote:

> I need to get Interchange 5.0 running on a RHEL 3.0 box. I understand that
> I cannot use the RPM version of Interchange due to problems with CPAN
> dependancies, etc.. I am assuming that I need to build Interchange from
> src tarball.
> Plan of attack:
> Download SRPM of perl 5.8.0; build non-thread version.
> rpm -e --nodeps of threaded perl that comes with RHEL3.0
> rpm -i --nodeps of non-threaded perl built from SRPM
> Download src tarball and install
> Are there any gotchas out there that I need to address before proceeding
> (i.e. any perl modules that I need to rebuild to work properly with
> non-threaded perl ... like mod_perl that comes stock)?

I would not remove the stock threaded perl. You'll cause all sorts 
of trouble and reduce the maintainability of the server in the long 
run, and long-term stability is likely the reason you're using RHEL 
in the first place.

Install your unthreaded build in the default location of /usr/local and
let Interchange use that. Also, there shouldn't be any reason to use 5.8.0
since 5.8.3 is out.


More information about the interchange-users mailing list