[ic] mod_interchange 1.30 Problem

Bryan D Gmyrek gmyrek at U.Arizona.EDU
Tue May 11 18:12:27 EDT 2004

> Bryan D Gmyrek [gmyrek at U.Arizona.EDU] wrote:
> > Thanks, Kevin, for mod_interchange.  It works great except when I try to
> > use the OrdinaryFileList directive.  When I add this along with
> > the other directives in httpd.conf and try to restart apache I get
> >
> > Syntax error on line 1378 of /usr/local/apache/conf/httpd.conf: Invalid
> > command 'OrdinaryFileList', perhaps mis-spelled or defined by a module not
> > included in the server configuration /usr/local/apache/bin/apachectl
> > startssl: httpd could not be started
> >
> > To make sure I re-downloaded the version of www.interchange.rtfm.info
> > today and re-installed.
> >
> > I'm using Apache 1.3.29, mod_interchange 1.30, redhat linux 9, and IC
> > 5.2.0
> >
> Did you have another version of mod_interchange installed prior to
> your installation of 1.30?  If so then make sure that you're
> overwriting the previous mod_interchange.so with the new version as
> it seems that perhaps the older version is still being used;  The
> OrdinaryFileList directive is new in version 1.30.

Checked and double checked this.  Before I copied the mod_interchange.so
file into the libexec directory I removed the 1.29 version.

> If this is a fresh installation then I can't think of a reason why
> only that single directive would be flagged.  Well, there's a chance
> that the module is not installed at all, and OrdinaryFileList was
> just picked by Apache as the directive to use in the error report.
> Try starting Apache without the OrdinaryFileList directive, to see
> if another directive gets used in the error message instead.

Actually, mod_interchange works as advertised when I don't use the
OrdinaryFileLis directive!  So basically, the answer to this q is no error
when OrdinaryFileList is removed.

> Can you make sure that mod_interchange is installed.  You should
> have the following directives in the appropriate place in your
> httpd.conf:
>     LoadModule interchange_module   libexec/mod_interchange.so
>     AddModule mod_interchange.c

Check, check.

> If you're sure that mod_interchange is installed then can you post
> your <VirtualHost> configuration block.  There may be something else
> in there that's causing problems.

NameVirtualHost xx.xx.xx.xx:80
<VirtualHost xx.xx.xx.xx:80>
DocumentRoot "/usr/local/apache/htdocs"
ServerName www.mydomain.com

<Location /mystore>
SetHandler interchange-handler
InterchangeServer  /opt/interchange/etc/socket
DropRequestList /default.ida /x.ida /cmd.exe /root.exe
OrdinaryFileList  /robots.txt /interchange/


This is the config that doesn't work.  Commenting out the
OrdinaryFileList will work and one can then access my store with www.mydomain.com/mystore/
(obviously once I get OrdinaryFileList working I will change <Location
/mystore> to <Location />

> I know that v1.30 works;  I use it myself and have had a couple of
> reports from others.  You're the first one to post a problem report.
> Congratulations. :-)

With accomplishments like mine who needs failures??


More information about the interchange-users mailing list