[ic] Interchange and https

Peter peter at pajamian.dhs.org
Sun May 16 02:20:35 EDT 2004

Mark Weaver wrote:
> I get this in the console:
> [root at amermicro1 conf]# apachectl startssl
> [Sun May 16 02:35:46 2004] [error] VirtualHost -- 
> mixing * ports and non-* ports with a NameVirtualHost address is not 
> supported, proceeding with undefined results

For the answer to this see here:

...and yes, apparently I was wrong about it defaulting to port 80, I 
could've sworn it worked that way.  Maybe it's a difference between 
apache 1.3 and 2.0.

> httpd (pid 32372) already running

You need to stop the httpd server before starting it the above way.

> "the connection to order.americanmicroinc.com has terminated 
> unexpetedly. Some data may have been transfered."

Some googling found that someone else had this same problem and solved 
it by changing thier allowable SSL ciphers:

However your SSLCipherSuite directive is exactly the same as mine, so I 
don't think that's the problem in your case, but it would likely be 
related.  AFAICT the error message means that SSL negotiation could not 
be completed between the server and the client, most likely because they 
couldn't find a cipher that both supports.  To me this suggests that 
your missing some or all cipher modules or libraries which is limiting 
the ciphers that apache can use to negotiate the connection with, it 
can't find one that the client also has and so the SSL connection fails. 
  Try this command to see which ciphers are supported by your version of 
openssl and make sure all the ciphers you have listed are supported:
openssl ciphers -v


More information about the interchange-users mailing list