[ic] [add-item] problem

Ed LaFrance (New Media E.M.S.) ic_users at newmediaems.com
Tue Nov 16 12:48:02 EST 2004

At 08:20 PM 11/15/2004, you wrote:

>I'm having some trouble with the add-item usertag.  I'm using it to
>add an item to the shopping cart based on user input before anything
>else is in the cart.  If the same item is then added to the cart
>through normal IC means, it is added as a new line instead of
>incrementing the original line item.  I do have "SeparateItems No" in
>my catalog.cfg and it works great otherwise.  Here's a link to the
>posted tag:
>Adding more of the item via a normal form increments the second line,
>and adding more of the item via [add-item] increments the first line.
>The whole thing does work properly if an item is added to the cart via
>normal IC means first and then added via [add-item].  Any ideas?
>- Grant

There is probably something different in the hash structure of each of the 
entries in question. I suggest you take a look at a dump of the cart data 
in your test condition to determine what that might be. I have not touched 
the [add-item] tag in some time but I would not be at all surprised if it 
is missing something...

- Ed

New Media E.M.S.              Technology Solutions for Business
11630 Fair Oaks Blvd., #250   eCommerce | Consulting | Hosting
Fair Oaks, CA  95628          Ed.LaFrance at newmediaems.com
(916) 961-0446                http://www.newmediaems.com
(866) 519-4680 Toll-Free      (916) 961-0447 Fax

More information about the interchange-users mailing list