[ic]Threads on Perl

Stefan Hornburg racke at linuxia.de
Sat Nov 20 05:23:12 EST 2004

On Fri, 19 Nov 2004 17:26:11 -0600
"Paul Arnold" <arnman at cox-internet.com> wrote:

> >
> >>>Hello,
> >>>I have searched High and low, and High and Low, and Haven't found a 
> >>>downloadable non-threaded perl for Fedora Core 3, or red hat 9. I have 
> >>>searched the icdevgroup site, and all over the internet.
> >>>I have tried the newest perl, and even the developemental version of 
> >>>perl, and during configuration, I select no to Threads when it asks.
> >>>But after all the install, I go to install IC, it gives me a Can't 
> >>>install because of Threads, type of answer.
> >>>I wonder what I can do to either download a unthreaded perl, or somehow 
> >>>make my perl install non-threaded.
> >
> > I guess you have another copy of Perl which confuses your IC
> This is what I have now, I reinstalled my FC3 and followed Brians 
> instructions on vermonster. Everything I saw I typed in and all worked. I 
> went to install the tar file of IC, and it started to install like magic. It 
> went all the way through until it said
> Writing /usr/local/interchange/auto/Interchange/.packlist
> /usr/bin/perl Makefile.PL force nocpaninstall= final=/usr/local/interchange
> and it is just hanging there. In fact, it has been an hour, I left it just 
> in case it was doing something in the background. and it is still on this 
> line.
> I check TOP and perl was using most of my cpu.
> Does it normally take this long? I even stopped it and ran make install and 
> it still says the same thing.

No, there is something wrong. You may examine your process list and then
strace the hanging process.


LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

More information about the interchange-users mailing list