Makecat Errors [IC]

joe joe at
Mon Oct 18 19:43:07 EDT 2004

Davor Ocelic wrote:
> Greetings and Salutations Joe,
>>In desperation I re-installed Debian pointing to the testing and 
>>managed to get IC 5.2 installed, but when I ran the makecat command it

>>also errors out with the same access denied creating directories.
> I have seen this. If we're talking about the same problem, then it 
> happens the interchange user can't create directories under
/var/www/shops/ .
> The solution is:
> mkdir -p /var/www/shops
> chown interchange.interchange /var/www/shops

Also, upon re-running makecat for whatever reason to (re)create a shop,
make sure that the destination dir, files and database dont already
exsist. If you get similair errors when starting up IC, first check on
ownership and rights or else you will be driving yourself crazy :)


Thank you for the replies. I now have this error:

Copying demo files..........................................No
/usr/lib/interchange/foundation directory is present,
where should the files come from?

I have tried to remove/re-install the IC package:

Any thoughts?


More information about the interchange-users mailing list