[ic] Image uploader breaks in 4.8.7 -> 5.2.0 upgrade

Peter N. interchange at framework.ws
Tue Aug 23 10:09:49 EDT 2005

>> I just updated a catalog from a 4.8.7 installation to a 5.2.0.
>> Everything works fine, except for image uploading.  When I attempt to
>> upload an image, I get an error in the log saying:
>> host70.catalog.com huRhk5Jw:catalog.com - [08/July/2005:17:41:03 
>> -0400] catalog /cgi-bin/catalog/admin/item_edit imgxyz.jpg is not a file.
>> I had similar problems under the 4.8.7 catalog, which I resolved by
>> adding a symlink to my image directory called "images" in my catalog
>> root.  The same symlink appears in the IC 5 version of the catalog, and
>> everything else (server, servername, user, file permissions) are the
>> same as with the 4.8.7 catalog, except file uploads don't work.
>I've had the same problem. All the permitions in the directories were ok but 
>each time I wanted  to upload a new picture, it wouldn't. I got an error in 
>the log "xxx is not a file".
>I solved the problem by merging the meta data, which hadn't been done before 
>because that too caused an error.
>Cannot merge metadata -- column(s) 'extended, default' is missing in table 
>So I fixed that by "CATDIR/products/mv_metadata.asc", adding 2 tabs at the end 
>of the first line and "extended". Then I restarted Interchange and merged the 
>metadata. After that the admin UI had changed somewhat. I could even upload a 
>3rd picture for each product... Image, Thumb and Large Image. Image and Large 
>Image worked but not Thumb. In order to get Thumb to work, I had to go to the 
>right side of the image uploading page (it's on another page now) , click on 
>the edit meta icon and then edit the "Filter(s)" filed to make it look like 
>for the other images fields (select the "--add--" filter and leave the edit 
>box on it right empty). Now Thumb works too! 

Hi list,

I tried this, as I also had not merged the metadata.  After merging, I 
now get the following in the error logs:

host70.catalog.com eYpBwjHd:catalog.com - [23/August/2005:09:51:21 
-0400] catalog5 /cgi-bin/catalog5/admin/item_edit failed to write 
images/items/Winter.jpg: Inappropriate ioctl for device
host70.catalog.com eYpBwjHd:catalog.com - [23/August/2005:09:51:21 
-0400] catalog5 /cgi-bin/catalog5/admin/item_edit No key 'code' found 
for function='update' table='products'

When I looked at the uploader meta information, the original 4.8 catalog had

while the 5.2 catalog had
<A HREF="admin/upload_file?ui_image_preview=[var 

I tried replacing the 5.2 code with the working 4.8 code, but nothing 
changed. Any more suggestions would be greatly appreciated.

Thank you,


More information about the interchange-users mailing list