[ic] mod_interchange and Apache MaxClients

Ron Phipps rphipps at reliant-solutions.com
Wed Dec 28 13:44:18 EST 2005

> From: John1
> Sent: Wednesday, December 28, 2005 5:56 AM
> On Thursday, December 22, 2005 11:12 AM, rphipps at reliant-solutions.com
> wrote:
> > I think we've found it occurs regardless of
> > version.  At least in my case I've tried different versions of
> > and mod_interchange and have seen posts from people using different
> > versions of IC (we are on modified version of 4.8.x).  It'll be
> > interesting to see if we have this same problem when we move to the
> > latest and greatest.
> >
> I think I have uncovered the reason for the problem.  I have managed
> write a script that emulates the worm's POST requests.
> The script will consistently crash our site (and presumably many other
> Interchange sites), so I thought it was best to send it to Kevin off
> rather than post details of the script to the mailing list.
> Ron/Jeff - If you wish, I can forward you a copy of the script and
> of the issue.
> BTW Ron, thanks for the suggestion of adding /xmlrpc.php to
> DropRequestList - this actually led to me uncovering the problem.
> /xmlrpc.php to Drop RequestList does also stop our site falling over,
> as
> you say it is masking the underlying problem.

That's great news John.  Please do send the script off-list to me.  I'll
try it against one of my development domains to see if we get the
crashing problem and I can then test whether cgi works without having to
automatically restart the ic server.  Keep us posted, thanks!


More information about the interchange-users mailing list