[ic] SQL::Parser message in error.log

Jon Jensen jon at endpoint.com
Thu Jan 6 23:57:51 EST 2005

On Thu, 6 Jan 2005, Nick Hall wrote:

> I suspect the problem possibly has to do with SQL::Statement, as the 
> server has version 1.09 installed, which installs a Parser.pm, and also 
> has version 0.1021 of SQL::Statement installed; the version 1.09 looks 
> like it has precedence over the older one. I've tried removing the 1.09 
> version files though and I haven't gotten anywhere, so I'm not sure if 
> I'm moving in the right direction.

That should do it. Interchange before 5.2 requires SQL::Statement < 1.0. 
(Newer versions of Interchange have a built-in SQL parser Mike Heins 
wrote.) Are you sure you removed all vestiges of that newer version, and 
restarted Interchange?


Jon Jensen
End Point Corporation
Software development with Interchange, Perl, PostgreSQL, Apache, Linux, ...

More information about the interchange-users mailing list