[ic] SQL::Parser message in error.log

Nick Hall selltothem at selltothem.com
Fri Jan 7 21:04:49 EST 2005

At 10:57 PM 1/6/2005, Jon Jensen wrote:
>On Thu, 6 Jan 2005, Nick Hall wrote:
>>I suspect the problem possibly has to do with SQL::Statement, as the 
>>server has version 1.09 installed, which installs a Parser.pm, and also 
>>has version 0.1021 of SQL::Statement installed; the version 1.09 looks 
>>like it has precedence over the older one. I've tried removing the 1.09 
>>version files though and I haven't gotten anywhere, so I'm not sure if 
>>I'm moving in the right direction.
>That should do it. Interchange before 5.2 requires SQL::Statement < 1.0. 
>(Newer versions of Interchange have a built-in SQL parser Mike Heins 
>wrote.) Are you sure you removed all vestiges of that newer version, and 
>restarted Interchange?

Yes, I have removed all the files from SQL::Statement 1.09 and all that's
left is 0.1021, and the error message is the same. I confirmed that it is
using 0.1021 because I then renamed the directory that 0.1021 is in and
several of my catalogs failed to start, saying:

Required Perl module SQL::Statement not present. Aborting catalog.

And one without the "Require module SQL::Statement" in the catalog.cfg
produced this in the error.log when the same page was loaded as with the
"object method "new" message":

Query rerouted from table products failed: SQL is not enabled for
Interchange. Get the SQL::Statement module.

so Interchange is indeed using the 0.1021 SQL::Statement (after I restored
that directory) but is still producing the error message.


More information about the interchange-users mailing list