[ic] Admin order entry failing

Glenn McCalley techlist at bnetmd.net
Fri Jan 21 16:49:53 EST 2005

----- Original Message ----- 
From: "Ethan Rowe" <ethan at endpoint.com>
To: <interchange-users at icdevgroup.org>
Sent: Friday, January 21, 2005 3:14 PM
Subject: Re: [ic] Admin order entry failing

> Glenn McCalley wrote:
> >Hi there,
> >Entering an order through the admin interface.
> >When one clicks "Place Order" one gets the error:
> >
> >Customer record creation: There was an error adding to the customer
> >table userdb: Attempt to write userdb::password::U03216 in read-only
> >
> >- This has never worked properly in this particular store.
> >- Same results regardless of the admin user ID used, including interch,
> >Site Administrator.
> >- Customer orders online are going well with no problems.
> >
> >The error.log shows:
> >...process Route log failed.
> >...process ERRORS on ORDER IS003718
> >...process Attempt to write userdb::password::U01956 in read-only table
> >...process Safe: Auto-create of user tailed. at (tag 'perl') line 1.
> >
> >which would seem to indicate a password error?
> >
> >
> I think the pertinent information is "in read-only table".
> It sounds to me like you need to use [tag flag write]userdb[/tag] to set
> the userdb writable on the order entry page (or in the order route;
> wherever it is that the user record is created in your catalog).  This
> needs to happen before any other access to the userdb table within that
> page.  I'd look here first.  This doesn't explain why the admin order
> entry works properly in other locations...
> >- Route log and Route entry are untouched from installation.
> >- I checked the posts from last summer that discussed an error creating a
> >customer record due to no password because of no zip code entered and
> >has a zip code.  Well, there is a 5 digit number in the box and the
> >edit passes.
> >- There is no existing user "U01956".  There is a U01955 and U01957.
> >- Unix permissions are the same as all our other stores.  Admin order
> >works OK in the other stores.
> >- It seems all stores share the same UI entry.html page so I wouldn't
> >that's it since other stores work OK.
> >
> >
> Perhaps there's some behavioral difference in how the UI entry is used
> between the stores?  Perhaps they only work with existing customers for
> other stores, or they always create the user account prior to order
> entry?  (Yes, these sound unlikely)
> >- comparison of catalog.cfg and variable.txt files with stores that work
> >doesn't seem to show anything of value.
> >
> >Ideas?
> >IC 5.2.0 / Perl 5.8 / Perl signals are unsafe / MaxServers = 0
> >Thanks!
> >Glenn.
> >
Hey, thanks for the note.
Agreed, it's a database access problem.  I added this to entry.html, about 6
lines into the file:

[tag flag write]userdb[/tag]

...no help.  Still get a file in "orders" with -0- bytes and the read-only
userdb error message.  An order number is used, and there -is- an entry in
the orders table interestingly enough.  If I could get the order to show up
with content in the orders directory I could live with the error message for
a couple of days.  At least the order would get out the door.

One thing I did try -- found refs to "Database   userdb    WRITE_CONTROL
1" in the docs.  Put that in with a WRITE_TAGGED after it and got about 400
error messages on the restart.  Wrong tree I suppose.


> >
> >
> >_______________________________________________
> >interchange-users mailing list
> >interchange-users at icdevgroup.org
> >http://www.icdevgroup.org/mailman/listinfo/interchange-users
> >
> >
> -- 
> Ethan Rowe
> End Point Corporation
> ethan at endpoint.com
> _______________________________________________
> interchange-users mailing list
> interchange-users at icdevgroup.org
> http://www.icdevgroup.org/mailman/listinfo/interchange-users

More information about the interchange-users mailing list