[ic] Barlink not searching locale products

Anthony van Winkle demandread at gmail.com
Fri Jan 28 19:25:55 EST 2005

Hello. I'm running Interchange 5.2.0 and have been able to find the
help to most of my questions on the archives, but not this one.

I'm running a single catalog with various locale settings for
different languages and pricing options. Defining different image
directories, price pictures and divides, and html suffixes all works
well. I've added the area and cat rows to locale.txt, so the
category_vertical properly displays bar_links in different languages.
So far, so good.

The problem I'm having is that the links in category_vertical are
still searching the original products database, and thus returning no
results. The foreign database (products_de_DE.gdbm) is fully
functional, because the random and cross_sell products all show up in
German. If I force the bar_link to search it (by adding
fi=products_de_DE) to the scan string then it returns properly. I
cannot figure out how to get the locale variable to influence this
automatically, however.

I've tried setting:
Locale de_DE ProductFiles products_de_DE variants_de_DE in the
catalog.cfg and etc/after.cfg, as well as products products_de_DE in
the locale database, but for the life of me I cannot get the bar_links
to search.

Your help is appreciated very much. The archives and error logs have
been of no aid on this, and I'm at a dead end. Thanks a million,

-Anthony van Winkle

More information about the interchange-users mailing list