[ic] Image uploader breaks in 4.8.7 -> 5.2.0 upgrade

Emmanuel Brun d'Aubignosc eba at upsylon.com
Mon Jul 18 11:03:44 EDT 2005


I've had the same problem. All the permitions in the directories were ok but 
each time I wanted  to upload a new picture, it wouldn't. I got an error in 
the log "xxx is not a file".

I solved the problem by merging the meta data, which hadn't been done before 
because that too caused an error.

Cannot merge metadata -- column(s) 'extended, default' is missing in table 

So I fixed that by "CATDIR/products/mv_metadata.asc", adding 2 tabs at the end 
of the first line and "extended". Then I restarted Interchange and merged the 
metadata. After that the admin UI had changed somewhat. I could even upload a 
3rd picture for each product... Image, Thumb and Large Image. Image and Large 
Image worked but not Thumb. In order to get Thumb to work, I had to go to the 
right side of the image uploading page (it's on another page now) , click on 
the edit meta icon and then edit the "Filter(s)" filed to make it look like 
for the other images fields (select the "--add--" filter and leave the edit 
box on it right empty). Now Thumb works too! 

So far everything seems to work...

I hope this was of some help.


PS: I wondered where I could find more documentation about how Interchange 
works inside? I first tried to look up the function that caused the error in 
the code. I couldn't find any comments explaining what it was doing (Perl not 
being the easiest language to read...)

More information about the interchange-users mailing list