[ic] Catalogs only work with --debug=1

Jon Jensen jon at endpoint.com
Mon Mar 14 12:12:13 EST 2005

On Sun, 13 Mar 2005, David xxxxxxx wrote:

> First, I want to thank you in advance for anybody who is able to help me
> with this problem.  I have used interchange for a long time on a few servers
> and recently moved to a new box.  I installed interchange-4.8.9-2 and copied
> the catalogs, websites, and databases to the new server.  Unfortunately, I
> cannot get the interchange site (or foundation demo) to work.  I receive the
> error message "We're sorry, the Interchange server is unavailable."
> I have checked my file permissions and ownerships and everything looks good.
> The cgi-bin directory has the correct permissions, as other scripts run
> fine.  The IC script has the following permissions:
> 	-rwsr-xr-x  1 interch  interch   6920 Mar  2 00:48 wildwoodwholesale
> I've thoroughly searched these message boards and found many suggestions,
> each of which I have tried to no avail.  Last night I noticed something else
> strange.  If I stop the interchange server and start it manually with
> "/usr/sbin/interchange --debug=1", it starts up in foreground mode and every
> catalog works perfectly -- but only in debug mode.  Seeing this, I tried
> instead setting "DEBUG 1" in the "/etc/interchange.cfg" file and it did not
> work.  Here is an error.log clip from starting the server using
> "/etc/init.d/interchange start":
> - - - [04/March/2005:22:38:46 -0500] - - Interchange V4.8.9
> - - - [04/March/2005:22:38:46 -0500] - - START server (21738) (UNIX)
> And this is the excerpt from starting the server using the --debug=1
> parameter:
> - - - [04/March/2005:22:40:09 -0500] - - Low traffic settings.
> - - - [04/March/2005:22:40:09 -0500] - - ...UI is loaded...
> - - - [04/March/2005:22:40:09 -0500] - - Interchange V4.8.9
> - - - [04/March/2005:22:40:09 -0500] - - Config 'wildwoodwholesale' at
> server startup
> - - - [04/March/2005:22:40:09 -0500] - - Config 'foundation' at server
> startup
> - - - [04/March/2005:22:40:09 -0500] - - START server (15447) (UNIX)
> - - - [04/March/2005:22:40:09 -0500] - - START server (15447) (UNIX)
> - - - [04/March/2005:22:40:09 -0500] - - Running in foreground, OS=linux,
> debug=1
> Does anybody have any idea why using --debug=1 makes a difference?  I can
> only run it in foreground mode and that just doesn't work for a live site.
> One more note -- this test holds true whether I use UNIX or INET mode.  When
> trying INET mode starting the server from /etc/init.d, I receive a
> connection refused error why trying to telnet to the Interchange port
> "telnet localhost 7786".  If it is started with the --debug=1 option, I can
> telnet to port 7786 just fine.  I've worked on this for a few days straight
> and I'm open for suggestions.  I've exhausted my Linux knowledge on this
> one!  FWIW, I'm using perl v5.8.5.


I assume you're using a non-threaded Perl in /usr/local/bin/perl, right? 
If you're not sure, do "/usr/local/bin/perl -V" and send the output here.

The first thing I'd do for a problem this strange is create a new OS user, 
and build Interchange from the source tarball there, totally separate from 
your other IC. Make sure to do "/usr/local/bin/perl ./configure" so you 
use your unthreaded Perl build. Copy in your catalog. Create a new CGI 
that will talk to that IC. And see what happens.

If you're not dependent on version 4.8 of Interchange, you'd might as well 
use the latest version of CVS while you're at it.

I don't recall you mentioning which distribution and version of Linux 
you're using, but since they started including threaded Perl builds, the 
RPM installation is less useful.


Jon Jensen
End Point Corporation
Software development with Interchange, Perl, PostgreSQL, Apache, Linux, ...

More information about the interchange-users mailing list