[ic] Catalogs only work with --debug=1

David xxxxxxx dxxxxxxx at cyber3dnet.com
Mon Mar 14 22:46:40 EST 2005

I'll try setting up Interchange as another user and see what happens.
Thanks for the reply.  Here is the output that you requested:

[root at host root]# /usr/local/bin/perl -V
Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
    osname=linux, osvers=2.4.20-021stab028.3.777-enterprise,
    uname='linux host.cyber3dnet.com 2.4.20-021stab028.3.777-enterprise #1
smp wed feb 2 21:08:59 msk 2005 i686 athlon i386 gnulinux '
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -I/usr/local/include
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
    cppflags='-fno-strict-aliasing -pipe -I/usr/local/include
    ccversion='', gccversion='3.3.3 20040412 (Red Hat Linux 3.3.3-7)',
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.3.3.so, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'

Characteristics of this binary (from libperl): 
  Compile-time options: USE_LARGE_FILES
  Built under linux
  Compiled at Mar  4 2005 01:28:00


-----Original Message-----
From: interchange-users-bounces at icdevgroup.org
[mailto:interchange-users-bounces at icdevgroup.org] On Behalf Of Jon Jensen
Sent: Monday, March 14, 2005 11:12 AM
To: interchange-users at icdevgroup.org
Subject: RE: [ic] Catalogs only work with --debug=1

On Sun, 13 Mar 2005, David xxxxxxx wrote:

> First, I want to thank you in advance for anybody who is able to help 
> me with this problem.  I have used interchange for a long time on a 
> few servers and recently moved to a new box.  I installed 
> interchange-4.8.9-2 and copied the catalogs, websites, and databases 
> to the new server.  Unfortunately, I cannot get the interchange site 
> (or foundation demo) to work.  I receive the error message "We're sorry,
the Interchange server is unavailable."
> I have checked my file permissions and ownerships and everything looks
> The cgi-bin directory has the correct permissions, as other scripts 
> run fine.  The IC script has the following permissions:
> 	-rwsr-xr-x  1 interch  interch   6920 Mar  2 00:48 wildwoodwholesale
> I've thoroughly searched these message boards and found many 
> suggestions, each of which I have tried to no avail.  Last night I 
> noticed something else strange.  If I stop the interchange server and 
> start it manually with "/usr/sbin/interchange --debug=1", it starts up 
> in foreground mode and every catalog works perfectly -- but only in 
> debug mode.  Seeing this, I tried instead setting "DEBUG 1" in the 
> "/etc/interchange.cfg" file and it did not work.  Here is an error.log 
> clip from starting the server using "/etc/init.d/interchange start":
> - - - [04/March/2005:22:38:46 -0500] - - Interchange V4.8.9
> - - - [04/March/2005:22:38:46 -0500] - - START server (21738) (UNIX)
> And this is the excerpt from starting the server using the --debug=1
> parameter:
> - - - [04/March/2005:22:40:09 -0500] - - Low traffic settings.
> - - - [04/March/2005:22:40:09 -0500] - - ...UI is loaded...
> - - - [04/March/2005:22:40:09 -0500] - - Interchange V4.8.9
> - - - [04/March/2005:22:40:09 -0500] - - Config 'wildwoodwholesale' at 
> server startup
> - - - [04/March/2005:22:40:09 -0500] - - Config 'foundation' at server 
> startup
> - - - [04/March/2005:22:40:09 -0500] - - START server (15447) (UNIX)
> - - - [04/March/2005:22:40:09 -0500] - - START server (15447) (UNIX)
> - - - [04/March/2005:22:40:09 -0500] - - Running in foreground, 
> OS=linux,
> debug=1
> Does anybody have any idea why using --debug=1 makes a difference?  I 
> can only run it in foreground mode and that just doesn't work for a live
> One more note -- this test holds true whether I use UNIX or INET mode.  
> When trying INET mode starting the server from /etc/init.d, I receive 
> a connection refused error why trying to telnet to the Interchange 
> port "telnet localhost 7786".  If it is started with the --debug=1 
> option, I can telnet to port 7786 just fine.  I've worked on this for 
> a few days straight and I'm open for suggestions.  I've exhausted my 
> Linux knowledge on this one!  FWIW, I'm using perl v5.8.5.


I assume you're using a non-threaded Perl in /usr/local/bin/perl, right? 
If you're not sure, do "/usr/local/bin/perl -V" and send the output here.

The first thing I'd do for a problem this strange is create a new OS user,
and build Interchange from the source tarball there, totally separate from
your other IC. Make sure to do "/usr/local/bin/perl ./configure" so you use
your unthreaded Perl build. Copy in your catalog. Create a new CGI that will
talk to that IC. And see what happens.

If you're not dependent on version 4.8 of Interchange, you'd might as well
use the latest version of CVS while you're at it.

I don't recall you mentioning which distribution and version of Linux you're
using, but since they started including threaded Perl builds, the RPM
installation is less useful.


Jon Jensen
End Point Corporation
Software development with Interchange, Perl, PostgreSQL, Apache, Linux, ...
interchange-users mailing list
interchange-users at icdevgroup.org

More information about the interchange-users mailing list