[ic] New installation of 5.2 won't start

James P. Kinney III jkinney at localnetsolutions.com
Thu Oct 20 15:23:54 EDT 2005

Still no clue on what was wrong, but I have it working now. I installed
the newest 5.2.1 tarball and everything worked just fine.

On Wed, 2005-10-19 at 23:35 -0400, James P. Kinney III wrote:
> I can't seem to locate a reference to what is going on. I have a Fedora
> 4 installation with the no-thread perl, postgresql, and the
> "kitchensink" IC perl modules. I'm trying to startup a brand new server
> with a fresh install of IC (and everything) and an empty products.txt
> file. The catalog is in the /home/<catalog name>/catalog directory as
> this is supposed to be a virtual hosted account. 
> The makecat process created the empty database OK. But all I get on
> startup is:
> <catalog name> config error: products not a database, cannot use as
> products file
> This leaves the interchange daemon running but with no active catalog to
> work with. I have tried making the permissions on the database wide open
> (localhost connects require no authentication at all), tinkering with
> the catalog.cfg file:
> ## Only search products table by default, don't want returns from any
> variants
> ## or other subsidiary ProductsFile
> Variable MV_DEFAULT_SEARCH_TABLE products
> Variable MV_DEFAULT_SEARCH_FILE  products
> ## Set which tables can contain products for order
> ProductFiles    products
> Changing the above products name to something else causes the error
> message to change to whatever is in the line but it still fails.
> _______________________________________________
> interchange-users mailing list
> interchange-users at icdevgroup.org
> http://www.icdevgroup.org/mailman/listinfo/interchange-users
James P. Kinney III          \Changing the mobile computing world/
CEO & Director of Engineering \          one Linux user         /
Local Net Solutions,LLC        \           at a time.          /
770-493-8244                    \.___________________________./

GPG ID: 829C6CA7 James P. Kinney III (M.S. Physics)
<jkinney at localnetsolutions.com>
Fingerprint = 3C9E 6366 54FC A3FE BA4D 0659 6190 ADC3 829C 6CA7
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://www.icdevgroup.org/pipermail/interchange-users/attachments/20051020/e6645570/attachment.bin

More information about the interchange-users mailing list