[ic] Upgrade Not a total failure (I hope)

JT Justman jt at airdelights.com
Thu Sep 22 18:39:23 EDT 2005

danfisher at bwkip.com wrote:
> Upgrading Interchange 4.8.61 to latest 5.2 on Redhat Linux 7.2
> I ran the following
> perl Makefile.pl prefix=/var/lib/interchange
> make
> make test
> make install
> service interchange restart
> Nothing failed - all tests passed and states install successful 
> Interchange restarted OK as well.
> I tried logging into the admin for interchange
> and it still states version 4.8.61 and no changes have been made to the
> admin interface or anything.
> Anyone else have this issue? If so how did you fix it?
> -Dan

Hi, Dan!

Are you sure you didn't end up with two interchange installations? In my
FC3 installation, the prefix is /usr/lib/interchange, and the catalogs
are stored in /var/lib/interchange. So you probably have Interchange
installed in /var/lib/interchange, and your scripts pointing to
/usr/lib/interchange or /usr/local/interchange.

You might want to use 'Linux Standard Base' style install:




More information about the interchange-users mailing list