[ic] Error moving cat to new server

curthauge at mnwebdesign.com curthauge at mnwebdesign.com
Sat Apr 22 13:56:03 EDT 2006

Hi list,

Fedora Core 4	IC5.2.0	Perl 5.8.8 unthreaded

Upon moving a working production site to a new server, we are getting this
error on startup:

Configuring catalog fts...table 'ups_cache' failed: table ups_cache connect
failed -- DBI connect
('ftsdb','',...) failed: Access denied for user 'fts'@'localhost' (using
password: NO) at /home/fts/interchange/lib/Vend/Table/DBI.pm line 574

fts config error: products not a database, cannot use as products file

fts: error in configuration. Skipping.
fts: config error. Skipping.
Interchange server started in UNIX mode(s) (process id 2815)

I get a similar error in /interchange/error.log:

- - - [22/April/2006:12:44:36 -0400] - - fts config error: products not a
database, cannot use as products file

and in catalog error.log I get the same error as the first one.

This client does not use UPS caching.

Here are some standard entries from catalog.cfg:
Database   ups_cache        ship/ups_cache.txt         __SQLDSN__
Database   ups_cache        AUTO_SEQUENCE  ups_cache_seq
Database   ups_cache        DEFAULT_TYPE varchar(12)
Database   ups_cache        INDEX  weight origin zip shipmode country

and this:

Shipping   default    dir   products/ship

ups_cache is located in CATROOT/products/ship containing only the field

If I create a new catalog things go good, but this existing cat is

I checked the mailing archives and google for the errors. I've tried
changing out my /dbconf/mysql/products.mysql file to an original foundation

Anybody got any other ideas?


Curt Hauge
Office 763-689-4984
Cell   612-598-5530

More information about the interchange-users mailing list