[ic] How to default image display

Gert van der Spoel ic at 3edge.com
Sat Apr 29 17:15:44 EDT 2006

sb at airdelights.com writes: 

> sb at airdelights.com writes:  
>> sb at airdelights.com writes: 
>>> I'm want to display an image in a simple fly page that calls the 
>>> image
>>> from items/[item-code].jpg If the image is not in the diretory for
>>> that part, I want interchange to display a default image.
>>> I have read in interchange mailing list that the data tag and if tag
>> is
>>> a good way to do this, but I'm having trouble getting it to work.
>> This
>>> is what I have so far, but I have not been able to get it to work: 
>>> <img src=[if type=file term="items/[item-code].jpg"]
>>> [else]
>>> 	items/1sna.jpg
>>> [/else]
>>> [/if] Border="0"> 
>> just a wild guess but try 
>> [if type=file term="images/items/[item-code].jpg"]  ... 
>> I gave it a try but did not make the item image display, still only 
>> get default image to display. steve
> Hi,  
> Below code works in a foundation store where the images are located at:
> <docroot>/standard/images/items/  
> Just create a testpage and put the code below in, replace <STICK HERE
> CODE> with one of your item codes.  It should show up twice, because 
> CODE> there
> are two ways below to do it. Also check the following variables:  
> IMAGE_DIR       /standard/images        Directories and Paths
> SAMPLEHTML      /www/htdocs/standard    Directories and Paths
> SAMPLEURL       http://its.a.server.nl/standard    Directories and Paths 
> [fly-list code="<STICK HERE ITEM CODE>"]  
> <img src="[if type=file term="images/items/[item-code].jpg"]
> items/[item-code].jpg"
> [else]
> items/1sna.jpg"
> [/else]
> [/if] Border="0">  
> [if type=file term="images/items/[item-code].jpg"]
> <img src="items/[item-code].jpg">
> [else]
> <img src="items/1sna.jpg">
> [/else]
> [/if]  
> [/fly-list]  
> CU,  
> Gert  
> Thank you Gert.  I tried both of these and had same effect, only showed
> the default items/1sna.jpg image.  So I tried changing the typ=file to
> type=image and then it displays the item-code image, but will not
> display the items/1sna.jpg default image for the items that have no
> image in the items/ folder. 
> Any suggestions?

what are the settings for you for:

?  It appears your path in the [if type=  is incorrect and is therefor not 
finding the files ... not totally sure - but what's the permissions of the 
image files?  perhaps IC can't read the files .... 



More information about the interchange-users mailing list