[ic] freebsd IC blank pages and premature end of script headers

Bill Beecham bill_beecham at hotmail.com
Sun Aug 20 22:29:29 EDT 2006

On 08/20/2006 11:50 AM, Bill Beecham wrote:
>Here are the answers to your questions:

Please don't top post. See

>IC Ver 4.8.3, mysql  Ver 14.7 Distrib 4.1.18, for portbld-freebsd5.5 (i386) 
>using  4.3
>No, this IS a new installation. This is not an old catalog that just 
>started freaking out, this is a fresh installation.

Why are you using such an old version of Interchange for a new install?
  That version is from 5 years ago.  Try 5.4.1 stable release with the
standard demo or 5.5.0 development release.


Well I took your advice and installed 5.4.1 and it still does the exact same 
thing. I did decide to view the raw web output of the blank pages. The pages 
actually are a server 500 error, plus it says it had trouble displaying an 
error page for the error page. Whatever that means.

So why would the admin section somewhat work, the checkout page work, but 
not the rest of the catalog? Also, my link file is only like 7,116 bytes in 
size. Does that sound right? I thought they were bigger, like almost 80k. 

This has me stumped. Would it be a path problem if part of the catalog works 
and part does not? I wouldn't think it was a permission problem, but I do 
still get the premature end of script headers and I cannot figure out why. 
My regular document root files work and show up fine, so does php. Php works 
with mysql as well.

So, I have an error 500 and premature end of script headers for index, and 
every other file in the catalog but the admin section and the checkout.html. 
Not sure why my pages are blank, the server should be able to show a 500 
file for the 500 error. It shows one for the 404. Not concerned about the 
error page.

So, any more ideas? Places to look? Things to try?


Express yourself instantly with MSN Messenger! Download today - it's FREE! 

More information about the interchange-users mailing list