[ic] freebsd IC blank pages and premature end of script headers

Bill Beecham bill_beecham at hotmail.com
Wed Aug 23 15:09:25 EDT 2006

On 08/21/2006 07:08 PM, Bill Beecham wrote:
>All of them but the small cart, full cart, small search. All others cause 
>the error and not one mention of it in any of the error logs, even with all 
>the debug turned on. Something is breaking before it even gets recorded as 

You'll need to pick the simplest of the components that is causing the
error and edit the component itself to try to determine which part of
the component is the cause.  Components are in templates/components.

>I just figured it was a db thing, outside of the admin section, because it 
>is each and every component that touches the db that causes the error.

Well, anything is possible, but I highly doubt it since if it were a db
thing the problem would happen in the admin UI as well.  It could be a
specific way of accessing the db, such as the [data] tag that is causing
the problem, though.



here's one for ya... I removed perl, recompiled it and re installed it. 
Removed and reinstalled the components. Same problem.

Here's another one for ya. Installed IC 4.8.3 and setup a catalog without 
mysql, just the dbm database and everything worked fine. All the pages, all 
the content, I even placed an order successfully.

That leads me back to something with how the data is accessed. That leads me 
to believe that the component tags are fine. I'm still thinking there's some 
little something to do with the dbd and dbi with mysql.

To check this out as best I could I wrote a small perl program that uses 
those drivers to access the database. No problems whatsoever. So then I 
downloaded a mysql manager in perl. Again, ran just fine. No problem 
accessing data.

So what on earth can it be? Could it be some permission set wrong for the 
database user? Or maybe the interch user I created doesn't have something 
set that should be?

Maybe you can tell me exactly what kind of system you run with the version 
numbers and all for the os, perl, web server, etc. Maybe I can have the 
server loaded with those versions so I can get this catalog going.

Perl still dumps core everytime I get the premature end of script error, yet 
that file can obviously run. The non-sql catalog generates no errors.

Does anyone know, am I wrong in my assumption that the component pages are 
the same code for sql or non? Is it just something in the .pm files or 
different .pm files used for sql or non?

I need some kind of comparison. I looked at the components and I don't see 
much correlation with all of them having some kind of tag that causes a core 
dump from perl.

Interestingly, I took the items.html file from admin area and moved it 
temporarily to the reg catalog pages and it still worked fine, so I know 
it's not just magically working in particular directory. When I move the 
privacypolicy page to the admin area it still causes an error and perl dumps 

After having redone the whole shebang, where do I look? Obviously it's 
capable of running but something somewhere is getting messed up when certain 
components are called. If they access data they crash it. If component does 
not access data it works fine.

Anyone out there, anyone, got an idea of what to look for? Some permission 
somewhere? Anything?

I've even removed and re-installed dbi and dbd::mysql, along with the 
kitchensink bundle. Still no go.

I can't believe that there is just nothing that can be done about this. But 
I do understand it could be any number of things. All I'm lookin for is some 
ideas, things to try, even a hail mary attempt at something is better than 
pulling out my hair 12 hrs a day everyday combing the list looking for 
anything even remotely similar.



All-in-one security and maintenance for your PC.  Get a free 90-day trial!   

More information about the interchange-users mailing list