[ic] freebsd IC blank pages and premature end of script headers

Peter peter at pajamian.dhs.org
Wed Aug 23 17:55:15 EDT 2006

On 08/23/2006 12:09 PM, Bill Beecham wrote:
> here's one for ya... I removed perl, recompiled it and re installed it. 
> Removed and reinstalled the components. Same problem.
> Here's another one for ya. Installed IC 4.8.3 and setup a catalog 
> without mysql, just the dbm database and everything worked fine. All the 
> pages, all the content, I even placed an order successfully.

Moved from further down:

 > Perl still dumps core everytime I get the premature end of script error,
 > yet that file can obviously run. The non-sql catalog generates no errors.

Then it probably is a problem with DBI or DBD:mysql.  The fact that you 
can access the db in some ways but not others says that it's all 
configured correctly.  The core dump suggests a defective perl or 
defective compiled module (such as DBI or DBD::mysql).  If it were a bug 
in Interchange then you would get some kind of error to explain it in 
one of your logs.  In a previous message you told me your version of Perl:

 > The perl version is: This is perl, v5.8.8 built for i386-freebsd-64int

That's the latest version, so you can't upgrade to newer but I also 
notice that it's a 64 bit version.  Not a lot of people are running 64 
bit yet and I tend to think that this may be a bug specifically related 
to 64 bit and it could be very specific to 64 bit perl and freebsd 
specifically with DBI.  Maybe try installing a 32 bit version instead. 
Other than that I'm not sure what to tell you, others have had problems 
with freebsd from time to time and maybe there's someone else on the 
list who can help you.

> Maybe you can tell me exactly what kind of system you run with the 
> version numbers and all for the os, perl, web server, etc. Maybe I can 
> have the server loaded with those versions so I can get this catalog going.

Me?  I run Centos Linux, a slightly older version of perl apache 2.0 web 
server IC 5.2 and Postgresql 8.0, but I know people who run several 
different combinations of OS, IC version, db, etc and none have had the 
problem you're describing.  Unless you want to switch from BSD to Linux, 
or want to switch to Postgresql I fail to see how it's relevent, though.

> Does anyone know, am I wrong in my assumption that the component pages 
> are the same code for sql or non? Is it just something in the .pm files 
> or different .pm files used for sql or non?

The component pages are the same, but the internal code in IC obviously 
accesses a text file differently than a db.

> After having redone the whole shebang, where do I look? Obviously it's 
> capable of running but something somewhere is getting messed up when 
> certain components are called. If they access data they crash it. If 
> component does not access data it works fine.
> Anyone out there, anyone, got an idea of what to look for? Some 
> permission somewhere? Anything?
> I've even removed and re-installed dbi and dbd::mysql, along with the 
> kitchensink bundle. Still no go.

Look to Perl.  Since you've re-installed everything like you say it's 
unlikely that you've gotten a corrupt download or compile and you've 
likely found a bug in Perl.  I think you can probably get rid of it if 
you install a 32 bit perl instead of 64.  Changing to a different DB, 
such as Postgresql may also work.

Good luck,


More information about the interchange-users mailing list