[ic] FW: Need help with install please. Newbie here...

Barb Sorensen barb at emeraldcitymusic.com
Fri Dec 15 00:57:13 EST 2006

HI Stefan.  Thanks
 OK I broke down and upgraded my server to "business" so I could have the
ssh access..
Firs thing I did was go to the ftp address.
 it asked me for a password and I entered it and then it gave me a list of
all the files in the directory for interchange. :)
Looks Like I have access
 then I clicked on the configure file since the README instructions day to
do that first
  then I clicked on Makefile.pl as per the instructions after the
./configure file ran it's course.
and it again asked me for user and password and then it too ran it's course,
installed to /interchange and said "done"

 then I wasn't sure where to go but I remembered that after I ran the
configure file that the instructions at that point said to also run
Makefuile/.pl ( which I did ) and then run "make" and then run "make test"
and then run " make install"

 so I type in /interchange/make and it began to churn away .... And it's
been going for a little while.. Should it take this long, or is it waiting
for another command?  I ddid not see a "make" file in the folder.. And I"m
not that familiar with ssh commands and perl... So not sure if this is right
or did Miss something?:
Where to now? It's still on "make".. Toiling away ...


------ Forwarded Message
From: Barb Sorensen <barb at emeraldcitymusic.com>
Date: Thu, 14 Dec 2006 12:54:43 -0600
To: <interchange-users at icdevgroup.org>
Subject: Need help with install please. Newbie here...

I am not a programmer or a geek guru but just hack my way through things
85% of the time I know what I"m doing  but this telnet stuff is new to

I downloaded, unzipped and uploaded the interchange package to my server.
 I am on 1and1.com and have a Home account (no ssh and no telnet apparently
as far as I can tell - I did not know I needed it to install interchange and
I just switched form my old host to 1and1.com and am beginning to think I
made am istake and hoping to salvage it somehow ..)

When I opened the read me file it says to run Makefile.PL..  Which I did and
it says it's installing Interchange

 but then the next instructions say to run "make" and some other commands
but that is where I get stuck..
 I know .. I haven't even left the starting gate and I"m excited about
getting there already LOL!

When I run "make" I get an error 404: not found message

Also.. The pages look like text pages not a pretty front. Is that supposed
to be that way?  Just wanting to be sure I am doing this correctly..

So then somewhere I stumbled across something that says I need telnet to
install it.. 
Is there a way to install without telnet?

My "home" package with 1and1.com says that instead of using tenet they use
ssh. And if I want to use the SSH I have to upgrade to the next bigger
"business" package  which is what I am trying to avoid doing as well.

Has anyone here on this list installed in a Home package on 1and1.com or
know how to go about this?


------ End of Forwarded Message

More information about the interchange-users mailing list