[ic] Can't locate set cronjob (was - Need help with install please. Newbie here)

Davor Ocelic docelic at mail.inet.hr
Fri Dec 15 15:16:45 EST 2006

On Fri, 15 Dec 2006 14:02:34 -0600
Barb Sorensen <barb at emeraldcitymusic.com> wrote:

> It began to run and then I got this
> "Can't locate Set/Crontab.pm in @INC"
> BEGIN failed--compilation aborted at
> Compilation failed in require at
> Compilation failed in require at blib/script/interchange line 249.
> BEGIN failed--compilation aborted at blib/script/interchange line 249.
> not ok 1
> server/startup........-rw-r--r--

Hey Barb. This means you need to install the Set::Crontab Perl module.
The common way to do this is to run 

	perl -MCPAN -e 'install "Set::Crontab"'

in your shell (at the place where you'll be running Interchange).

Since this will most likely be the first time you are invoking CPAN
there, CPAN will ask you a series of questions to configure itself.
You should find a way about it since just accepting the defaults
works most of the time.

Once CPAN is configured, it will download the said Perl module,
compile and install it. Then resume your installation procedure from
and including the command that gave the error onwards.


More information about the interchange-users mailing list