[ic] Assistance Request

Daniel Degotardi daniel at hinterlands.com.au
Wed Jan 11 17:59:43 EST 2006

> I am fairly certain that this is the problem causing the error state:
> "serv /cgi-bin/serv/index.html Runtime error: table tree 
> connect failed
> -- DBI connect('*****','*****',...) failed: Can't connect to 
> local MySQL server through socket '/var/lib/mysql/mysql.sock' 
> (2) at /home/*****/interchange/lib/Vend/Table/DBI.pm line 581"
> That error is in my catalog error.log.
> The corresponding error from my Apache log is:
> "[Wed Jan 11 01:47:25 2006] [error] [client ***.***.***.***] 
> Premature end of script headers: /home/*****/public_html/cgi-bin/serv"

You are not alone! I have a very similar problem when installing interchange
onto centos 4.0 (non selinux). Interchange starts fine saying it is using
the correct mysql database. However as soon as an interchange page tries to
hit the database I get an internal server error and the following in the
interchange logs:

catalog_name /cgi-bin/catalog_name Runtime error: connect failed -- DBI
connect('catalog_db','catalog_db',...) failed: Can't connect to local MySQL
server through socket '/var/lib/mysql/mysql.sock' (2) at
/home/catalog/ic/lib/Vend/Table/DBI.pm line 571

Depending on the page requested the error is a little different in that it
says what table it couldn't connect to.

Unlike you I have not noticed being able to view pages when logged in via
ssh. I get internal server errors no matter what.

I've tried IC versions from 4.8 up to the latest stable. All display the
same symptoms.

The really crazy thing is that I have two other interchange installs on this
same server that run fine. I only have this problem when installing new
instances of IC from source. The two working installs were brought over from
an old server a few months ago.

I even tried installing IC on a dev server and then moving the install over
to the live site. It worked fine on the dev site and gave the mysql error on
the live site.

I'd pretty much given up trying to fix it because I couldn't see anyone else
on the list having the problem.

More information about the interchange-users mailing list