[ic] Assistance Request

Simon Swegles simon at swegles.com
Fri Jan 13 18:58:01 EST 2006

Marty Tennison wrote:

> Here are some ideas in case you have not tried them already.   Hope 
> they help.
> 1) Starting Interchange from the root cron job to see what happens.  
> Something like (/sbin/service interchange restart
> or su - c /.../interchange -r -l interch)
> 2) Eliminate SSH as a cause by logging in via telnet or direct 
> connection and see what happens.
> 3) Stop all unnecessary server processes except Interchange httpd and 
> Mysqld.
> 4) Use strace to debug at the system calls level.

Thanks for the suggestions. The results:

Starting IC while logged into root with the following commandline 
resulted in the same error state:
su -c "/home/*****/interchange/bin/interchange -r" icuser

Starting IC logged locally into the server returns the same error state 
behavior whether running from the IC user 
(/home/*****/interchange/bin/interchange) or as root (su -c 
"/home/*****/interchange/bin/interchange -r" icuser).

I killed all extra processes. Same error state after restarting the server.

Unfortunately, the strace output is a bit beyond my understanding right 
now. It is 503 lines of code, none of which stands out as being an error 
or particularly out of place to me. If there are likey to be any smoking 
guns, I would appreciate you sharing with me. If you are interested in 
the strace output I have placed it here:

More information about the interchange-users mailing list