[ic] Intchg 4.6.5 cannot find Digest::MD5...

Mike Heins mike at perusion.com
Tue Jan 24 09:29:31 EST 2006

Quoting Kevin Walsh (kevin at cursor.biz):
> "Goss, Clayton" <cgoss at foxfireprinting.com> wrote:
> > [root at DE-FF-RH7_2 root]# whereis perl
> > perl: /usr/bin/perl /usr/local/bin/perl /usr/share/man/man1/perl.1.gz
> >
> > [root at DE-FF-RH7_2 root]# /usr/bin/perl -MDigest::MD5 -le 'print
> > $Digest::MD5::VERSION'
> > 2.36
> >
> > [root at DE-FF-RH7_2 root]# /usr/local/bin/perl -MDigest::MD5 -le 'print
> > $Digest::MD5::VERSION'
> > 2.36
> > 
> > For some reason, interchange 4.6.5 just does not recognize the module.  
> > 
> I don't know what more to suggest from here, unless it's something
> silly such as file permissions on the module (read-only for root?)
> or a weird security/chroot environment.  I'm assuming that the module
> installed cleanly, with no errors reported in the test phase.
> It shouldn't take long to fix interactively (logged in and able to look
> around and experiment), but I can't think of anything further to suggest
> remotely, short of upgrading everything.  All of the version numbers
> you've quoted (Apache, Interchange, the Red Hat distro, Perl etc.) are
> very old.  Well, apart from the Digest::MD5 module which, ironically,
> is bang up to date. :-)

It sounds like the error he is getting comes from catalog.cfg, which
is easily ignored by removing the "Require Digest::MD5" line from
that file. Did 4.6.5 even have the "Require" directive?  I can't
remember when I put it in.

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.647.1295  tollfree 800-949-1889 <mike at perusion.com>

Unix version of an Outlook-style virus:
It works on the honor system. Please forward this message to everyone
you know, and delete a bunch of your files at random.

More information about the interchange-users mailing list