[ic] $Tag->data in a UserTag

Brent Kelly brent at zeald.com
Mon Jul 31 01:19:10 EDT 2006

Hmm if what you say is accurate then the only thing it could be is
that your $variable is not set to what you are expecting it to be.

I'd try either ::logError( "my var is $variable") & check your
error.log or to be sure of its value try:

my $var = '00123';
my $new_var = $::Tag->data( { table => 'mytable', field => 'myfield',
key => $var } );

If that works then try log var at a number of places throughout the
page & see whats happening to it because if its working when
hardcoded then i'll be a silly mistake most likely.

Brent Kelly

On 4:46:32 pm 07/31/06 Grant  wrote:> Try:
> my $new_var = $::Tag->data( { table => 'mytable', field =>
> key => $key } );
> Note the double colon in $::Tag->...

That's actually not working either.  If I hard-code the key value
the rest of the parameters it works, but not if I try to use a

- Grant

> On 12:05:53 pm 07/31/06 Grant  wrote:I'm having trouble getting the
> data tag to work inside a usertag when
> I specify one of the tag's fields with a $variable.  I've tried
> of these:
> my $new_variable = $Tag->data({table => 'table_name', field =>
> 'field_name', key => $variable});
> my $new_variable = tag_data('table_name', 'field_name', $variable);
> and I've fiddled with ',",q{}, and qq{} quite a bit too.  Does
> know how to make this work?
> - Grant
interchange-users mailing list
interchange-users at icdevgroup.org

More information about the interchange-users mailing list