[ic] swish search and parentheses - bug?

Dan Bergan dan at berganconsulting.com
Thu Jun 1 15:47:15 EDT 2006

I was looking through my interchange search log and noticed a strange 
result.  One of my customers searched for something like the following:
term1 term2 (term3)

That search returned zero results.  All three terms were valid and 
should have been found, so I did some testing and found that if I entered:
term1 term2 term3
I would find results, but if I included the parentheses then it would 
return zero results.
(by the way, I also tried this on the icdevgroup.org site and I'm seeing 
the same results.)

I tried to run the swish search at the command line, and I received the 
bash: syntax error near unexpected token `(t'

So, it looks like quotes are needed around the entire phrase if 
parentheses are used.  (The search worked fine from the command line 
with "term1 term2 (term3)").  But, I don't think my users are 
sophisticated enough to be using complex boolean searches anyway, so, I 
guess my question is: can someone give me some pointers on how to strip 
out those characters before the search executes?

Dan Bergan

More information about the interchange-users mailing list