[ic] adding fields to transaction table

ic at 3edge.com ic at 3edge.com
Mon Nov 6 06:32:47 EST 2006

> On 06/11/06, ic at 3edge.com <ic at 3edge.com> wrote:
>> graham hadgraft writes: 
>> > Can someone explain this message please.  I have added a field to the
>> > end of the transactions table and have added this field in the imnport
>> > tag of log_transaction in the retc folder however when someone tries
>> > to place an order this error is thrown.
>> >
>> > There were errors in your last submission:
>> >
>> >    (log_orderline_table): There was an error adding the order to the
>> > transaction table. It was: import into transactions failed:
>> > DBD::mysql::st execute failed: Column count doesn't match value count
>> > at row 1 at
>> > /home/httpd/vhosts/clearly-av.co.uk/interchange/lib/Vend/Table/DBI.pm
>> > line 1396, chunk 1.
>> >
>> > Please correct the areas listed above which are highlighted in this
>> > color in the form. 
>> Sounds like your Mysql DB is not in sync with what you try to put into it 
>> in
>> etc/log_transaction. Have a check on your DB table (describe orderline) 
>> and
>> see if your field is actually there. Did you restart IC at any point?
graham hadgraft writes:
> The two tables are in sync, i had indeed forgotten to restart
> interchange after editing log_transaction, but i have tried it now and
> the same error occurs. 
> Would it be an error with the orderline table when it says import into
> transactions failed. 

I don't know about your set up so BE VERY CAREFUL in case you try to follow 
any of the following. 

Did you update the file in:
dbconf/mysql/transactions.mysql    (adding the new field) 

Did you update the file in:
products/transactions.txt          (adding the new field to the header) 

Did you then remove:

And then restarted IC? 

NOTE: if your transactions.txt is not having the latest content of your 
database you will lose data, so if you do this please be careful, make sure 
you have made backups of your database before trying any of this. 

The error message as it is "There was an error adding the order to the 
transaction table" only appears once in log_transaction, so I'm pretty sure 
it's about your transactions table. the 'log_orderline_table' I think is 
just not correctly put in the [catch] tag. 



More information about the interchange-users mailing list