[ic] Upgrade 5.0 -> 5.5 via cvs resulted broken catalogs

Daniel Davenport DDavenport at newagedigital.com
Thu Oct 26 19:33:42 EDT 2006

> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org 
> [mailto:interchange-users-bounces at icdevgroup.org] On Behalf Of David
> Sent: 2006 October 26 -- Thursday 2:58 PM
> To: interchange-users at icdevgroup.org
> Subject: [ic] Upgrade 5.0 -> 5.5 via cvs resulted broken catalogs
> I've run into some problems upgrading from 5.0 -> 5.5.0 I'd 
> like to correct
> some variables if I could only stay logged in to the Admin. 
> It keeps booting
> me off back to the login page. It doesn't allow me as superuser to
> regenerate or do anything that requires superuser privileges. Any
> suggestions would be great. -- David

Anything you can do from the UI, and more, can be done from a shell

Edit $CATROOT/products/variable.txt to change your variables.  Mind the
tabs; don't delete any.
su -c "$ICROOT/bin/interchange --restart" $ICUSER to restart IC.

where $CATROOT is your catalog directory, and $ICROOT where IC itself
$ICUSER is the user ic runs as ("interch", for many people).

>           'SERVER_SOFTWARE' => 'Apache/1.3.37 (Unix) 

I so wish people would go ahead and upgrade to apache 2 already.  I
mean, it's only been around for 4+ years...

Daniel Davenport
New Age Digital

More information about the interchange-users mailing list