AW: [ic] GlobalSub Question

Lars Tode lars.tode at
Thu Apr 26 02:30:38 EDT 2007

Hi Kevin,

Thanks for your reply.

> I just added the exact same GlobalSub line to an 
> interchange.cfg file (all on one line.  I'm assuming it 
> wrapped in your email).  I also added the exact same Require 
> line to a catalog.cfg and restarted Interchange.
> I didn't get the error message you reported.

Yes it was wraped by the client. The GlobalSub is just one line.
> You didn't say which Interchange version you're using.  I 
> tried this on the latest 5.0.0 and it worked.  I wouldn't 
> expect a failure on any other version either.

It is Interchange 5.4.0, the latest stable release.

> The only thing I can think of is that the distributed 
> interchange.cfg file wraps the test GlobalSub in a "ifdef 
> @DEBUG" block.  Check for the "Sending debug messages to 
> debug.log." message when you start Interchange.  If you don't 
> get that message then perhaps @DEBUG is not set.  Scroll to 
> the top of the file and uncomment the "Variable DEBUG 1"
> line.

Thanks for the hint. I got a lot of error messages.
It seems that if you insert a second GlobalSub that produce an error,
all other GlobalSubs are not loaded by Interchange.
It would be great if failures in a GlobalSub produce the same messages
at start of Interchange as UserTags .

By the way, the second GlobalSub produce following messages:
Global symbol "$Session" requires explicit package name at (eval 16)
line 18, <GLOBAL> line 80.
Global symbol "$Tag" requires explicit package name at (eval 16) line
25, <GLOBAL> line 80.
Global symbol "$Values" requires explicit package name at (eval 16) line
30, <GLOBAL> line 80.

I'm suprised that it ist not possible to access Interchange variables
within a GlobalSub.

The reason of using the GlobalSub instead of Sub is, that I have
problems to access the database using the %Db hash.
I have written a UserTag, for the CartTrigger, that should store
informations in the database. If the Tag is called within an Interchange
Template, it works fine. If it was calles in a Sub (that is used for the
trigger), the access to the database failed.

Any ideas?

Thanks in Advanced,


More information about the interchange-users mailing list