[ic] Re: Payment.pm, Authorize.Net and wget - Problem Solved

havoc havoc at havoc.org
Tue Feb 6 06:45:18 EST 2007

On Tuesday 06 February 2007 05:30, Peter wrote:
> > I changed "system @args;" to "system(join(" ", @args));"  in
> > lib/Vend/Payment.pm and it works now, why, I'm not sure.
> > I realize one is "system LIST" and one is "system SCALAR", but either
> > *should* work.  I had dumped %ENV to the debug log and both calls had the
> > same %ENV. I'm just guessing that the LIST call was failing due to some
> > configuration specific to this machine.
> I suspect strange whitespace chars in the @args that are mitigated by
> joining together with space.  What do you get in your debug log if you
> add the line:
> logDebug(::uneval({'@args' => \@args}));

Then I suspect it would be:
	Route  authorizenet  use_wget     "/usr/local/bin/wget --no-check-certificate"

So $cmd would be "/usr/local/bin/wget --no-check-certificate"


   - havoc

More information about the interchange-users mailing list