[ic] interchange.pid

Mike Heins mike at perusion.com
Fri Nov 16 09:25:00 EST 2007

Quoting Brian Pribis (brian.pribis at gmail.com):
> Thanks for the quick response!
> >The exact error message would be good to add here. And interchange is 
> >running fine, until you try a shutdown / restart?
> >
> The exact error message is:
> "The previous Interchange server was not running and probably terminated 
> with an error."
> In fact, the interchange server is running.  The interchange.pid file 
> even has the correct pid. 
> >Tried setting it to 666 just to see what happens?
> It doesn't help.  If I delete the interchange.pid file and restart the 
> IC, it gets created (with 600) and the correct pid is put in it.  It 
> only seems to be a problem at shutdown.  (I see I have another response 
> from someone else.  I'll check that out and see what comes of it).

The problem is just trying to find the lock status. Have you tried

	LockType fcntl

in interchange.cfg?

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.647.1295  tollfree 800-949-1889 <mike at perusion.com>

Research is what I'm doing when I don't know what I'm doing.
-- Wernher Von Braun

More information about the interchange-users mailing list