[ic] We're sorry, the Interchange server is unavailable

Gert van der Spoel gert at 3edge.com
Fri Aug 15 10:17:59 UTC 2008

> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org [mailto:interchange-
> users-bounces at icdevgroup.org] On Behalf Of Michael J. Curtis
> Sent: vrijdag 15 augustus 2008 12:50
> To: interchange-users at icdevgroup.org
> Subject: [ic] We're sorry, the Interchange server is unavailable
> [ic] 5.6
> Ubuntu 8.4 Server
> Perl 5.88 (Threaded, had problems trying to compile a non-threaded
> instance on Ubuntu, no problems using threaded Perl on Fedora)
> Hi all
> I have for some time now been able to install and use Interchange on
> Fedora but now want to install on a much leaner/meaner OS configured as
> a LAMP server as a VM, so no X, Windows Manager etc
> I do realize that Ubuntu Apache configuration is different in some
> respect to Apache on Fedora, that is, no httpd.conf for makecat to
> parse and this may be the cause of my problem
> The index page in html space shows but when clicking on the catalog
> link on the page, eventually the above error shows
> All permissions look good
> When creating the catalog then UNIX sockets are used
> cgi-dir = /usr/apache2/cgi-bin and using the default instance of
> 'available-servers'
> When starting Interchange the database is created and Interchange
> process runs according to ps -ax
> It looks as though the link program does not know that Interchange
> exists?
> One thing that I have noticed is that the link program in my Fedora
> cgi-bin dir is approx 7K but the link program in my Ubuntu
> /usr/apache2/cgi-bin dir is a bit over 11K?.  I do not understand the
> reason for the difference

Nothing in your error logs to give an idea?
S bit is set on the link program?
No selinux running by any chance?



More information about the interchange-users mailing list