[ic] We're sorry, the Interchange server is unavailable

Davor Ocelic docelic at spinlocksolutions.com
Fri Aug 15 21:21:12 UTC 2008

On Fri, 15 Aug 2008 17:06:47 -0400
Richard Siddall <richard.siddall at elirion.net> wrote:
> I ran into a problem with similar symptoms earlier this week. 
> (interchange process running but not listening on any sockets. 
> interchange worked when run in debug mode.)  Try changing the setting
> of MV_GETPPID_BROKEN in interchange.cfg as it may be stalled trying
> to get the PPID.

When you install Interchange from the tarball, the usual install
routine goes like this:

perl Makefile.PL
make test
make install

Here, in the 'make test' step, any and all errors are detected,
upon which you can take appropriate action.

Even if you do not want to install IC from the tarball, you can
still download it and run the first three commands (all but the
final 'make install') in there to test and see whether IC can run
on your system properly.

Most commonly, when this gettpid thing is the problem, instead 
of seeing message a-la

... running in INET mode... OK.

you will see some long directory listing after which the test
routine will exit with a failure.


More information about the interchange-users mailing list