[ic] re: installing / permission denied.. ack!

Peter peter at pajamian.dhs.org
Mon Jan 14 06:59:09 EST 2008

On 01/13/2008 11:11 PM, Announcements from Emerald CIty Music 
Productions, Inc. wrote:
> HI I am installing interchange on my MAC and have perl 5.8.1 in the 
> system folder.
> when I input the address and type Makefile.PL.. I get an error message 
> saying:
> that permission denied.

It sounds like you're trying to run Makefile.pl from a browser, you 
can't do that.  You need to run it from a terminal or shell.

If that's not the case please provide more detail of exactly what you're 
trying to do and the exact error message you get, not just generalizations.

> so then I figured maybe because it's perl 5.8.1 and not 5.6.2 as per the 
> documentation.. so I downloaded 5.6.2 and put it in the system folder. 
> but it won't let me put it there.. ugh

It's 5.6.2 or later, 5.8.1 is good enough, but you should check that 
it's non-threaded ("perl --version" will tell you if it's threaded). 
Otherwise download and compile the latest 5.8 version of perl (I believe 
5.8.10).  5.8.1 is early in the 5.8 release cycle and now considered old 
and buggy (5.6.2 is *way* old).  I can't give specifics of where to put 
it on a mac, though.


More information about the interchange-users mailing list