[ic] IC 5.6.0 fresh install : catalog loose MysQL...

David Bordas bordas at testadaz.com
Sun Oct 19 11:42:35 UTC 2008

Hi interchange users,

I've got a strange problem with interchange. Now my catalog can't 
launched with mysql and want back to DBM mode...

My story :
I want to change my test serveur to CentOS 4 to Centos 5.2 x86_64.

So, i've installed all i need : Apache, MySQL, non thread perl in 
/usr/local/perl ...
Interchange 5.6.0 : like a charm

Then i've copied my catalogs directory back, put *.cfg (old conf) to 
interchange directory.
(catalog was build (several weeks ago) through 5.2.0 interchange and 
then upgraded to 5.6.0).

And now, lanching interchange :
cd /usr/local/interchange
su -c "bin/interchange -start" myuser

Output :
Low traffic settings.
Calling UI......UI is loaded...
Interchange V5.6.0
Running with old signals.
Configuring catalog mycat...Using default DBM database...done.
Interchange server started in UNIX mode(s) (process id 12977)

I can't understand why mysql is not activated and i fall back to DBM. :(

A perl script with DBI & DBD::MySQL is working, so perl seems to be working.
MySQL is up and running, interchange mysql user is working (i've tried)
I've tried to put back my all interchange directory and launch 
interchange, same thing.

Then i've create a new catalog (mysql_test) and for this one, mysql is 
ok with interchange !

Did someone have already see this behavior ?

Thank you !

David / Testadaz.com

More information about the interchange-users mailing list