[ic] "Byte order is not compatible" from moving sessions 32-bit -> 64-bit?

Jon Jensen jon at endpoint.com
Wed Aug 12 20:48:21 UTC 2009

On Wed, 12 Aug 2009, Grant wrote:

> I just moved a catalog from a 32-bit system to a 64-bit system, and I 
> noticed this error popping up intermittently in the global error.log:
> /page.html Died in server spawn: Byte order is not compatible at
> blib/lib/Storable.pm (autosplit into
> blib/lib/auto/Storable/_retrieve.al) line 380, at
> /usr/local/interchange/lib/Vend/SessionFile.pm line 77
> I did some searching on Google and it sounds like it could be caused
> from copying sessions from the 32-bit system to the 64-bit system,
> since I copied the entire catalog across.  I'm hoping these disappear
> as the old sessions expire.  Just thought I'd mention it in case
> someone else sees the same errors.

Yep, that's the cause.

It's best to delete all sessions when migrating across platforms, and even 
now, you could do a find | xargs rm to remove all sessions older than your 
new site went live so that visitors with an old session don't get an 
error, but get a new session instead.


Jon Jensen
End Point Corporation

More information about the interchange-users mailing list